Bug: Tamer Kabil's Quest Part V

Discussion in 'Quest Discussion' started by Halfwise, Feb 15, 2016.

  1. Halfwise

    Halfwise Dalayan Beginner

    Joined:
    Feb 6, 2016
    Messages:
    10
    Gender:
    Male
    Location: Grobb
    General Category: Beastlord Newbie Quests
    Character: Seiryuu, 11 Beastlord, Iksar

    I was going to post this in the Newbie Quest Bug thread, but the OP lists very specific quests (that don't include this one), so I made a new post.

    Upon (finally) completely part IV of this quest, I attempt to use the conversation option to bring up the next portion, but no response back. The character will just look at me. I have checked both the regular "Say" chat and the NPC responses (sometimes it jumps between).

    Additionally, I decided to try and complete the quest just by following the wiki. I have already completed the escaped animal heads, but the liodreth hands never dropped. I have killed the escaped liodreth ~12 times, with the hands never dropping. So I can't turn in the quest items to see if its broken anyway. (I know its the right NPC, based on the wiki. If for some reason it got switched over to the escaped liodreth trader, that would be very silly, as the trader is dramatically higher in level than that of the quests.)

    I'd be willing to test if the turn-in worked if anyone wanted to just give me the hands, or assure me that they do drop (if its just really really rare, though not sure why something's hands would be a rare drop)
     
    Last edited: Feb 15, 2016
  2. Voronka

    Voronka Dalayan Beginner

    Joined:
    Sep 29, 2011
    Messages:
    1
    Location:
    USA
    Almost a year late for the party, but I saw this topic and I literally just did that quest chain on my beastlord yesterday - so I wanted to say that I ran into this problem too. Yes, I was still able to complete the quest despite it.

    The last dialogue choice my character got to was "What do you mean, a liodreth?' And then, nothing. The Tamer Kabil's response doesn't trigger. Hailing him again got me silence - and hitting /cm d1 just made my BST repeat that line over.

    I went by the wiki to continue - and either the quest is glitchy, or the wiki is wrong about the actual liodreth you're suppose to kill. Killed "an escaped liodreth" 3 times, no hands. May have continued to work on him, but the "Escaped Liodreth Animal Trader" was also up, so I figured I'd give it a try (so I don't know if the hands from an escaped liodreth would have eventually dropped or not). Got Liodreth Hands on the first kill from the escaped liodreth animal trader. Those hands, along with the leashes, worked just fine when I turned them in to Tamer Kabil - got the end dialogue, the exp, the reward, and the quest completed as normal.

    The dialogue(the one that never appears haha) kind of implies that it's a liodreth trader you need, so maybe it's suppose to be like that. Was definitely pretty confusing though.
     

Share This Page